Gemini Community Support Site

This Gemini community support site can be used to find solutions to product issues. You can log in using Open Id, Google Profile and even Facebook. Feel free to ask a question or browse FAQs and documentation. Product tour videos are also available along with how-to videos demonstrating key Gemini capabilities.




2.1.1 Anonymous Redirecting

web-app

I have looked through the forums for similar problems and found similar but nothing from those posts have helped me so far.

I am logged in, in IE as the main administrator.  I was trying to test out anonymous rights be going to firefox and checking out the site.  Firefox says:

The page isn't redirecting properly

      Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

          *   This problem can sometimes be caused by disabling or refusing to accept
          cookies.

This is the relevant part of the URL when firefox displays the above message: http://www.atenveldt.org/gemini/Main.aspx?ReturnUrl=%2fgemini%2fMain.aspx%3fReturnUrl%3d%252fgemini%252fMain.aspx%253fReturnUrl%253d%25252fgemini%25252fMain.aspx%25253fReturnUrl%25253d%2525252fgemini%2525252fMain.aspx%2525253fReturnUrl%2525253d%252525252fgemini%252525252fMain.aspx%252525253fReturnUrl%252525253d%25252525252fgemini%25252525252fMain.aspx%25252525253fReturnUrl%25252525253d%2525252525252fgemini%2525252525252fMain.aspx%2525252525253fReturnUrl%2525252525253d%252525252525252fgemini%252525252525252fMain.aspx%252525252525253fReturnUrl%252525252525253d%25252525252525252fgemini%25252525252525252fMain.aspx%25252525252525253fReturnUrl%25252525252525253d%2525252525252525252fgemini%2525252525252525252fMain.aspx%2525252525252525253fReturnUrl%2525252525252525253d%252525252525252525252fgemini%252525252525252525252fMain.aspx%252525252525252525253fReturnUrl%252525252525252525253d%25252525252525252525252fgemini%25252525252525252525252fMain.aspx%25252525252525252525253fReturnUrl%25252525252525252525253d%2525252525252525252525252fgemini%2525252525252525252525252fMain.aspx%2525252525252525252525253fReturnUrl%2525252525252525252525253d%252525252525252525252525252fgemini%252525252525252525252525252fMain.aspx%252525252525252525252525253fReturnUrl%252525252525252525252525253d%25252525252525252525252525252fgemini%25252525252525252525252525252fMain.aspx%25252525252525252525252525253fReturnUrl%25252525252525252525252525253d%2525252525252525252525252525252fgemini%2525252525252525252525252525252fMain.aspx%2525252525252525252525252525253fReturnUrl%2525252525252525252525252525253d%252525252525252525252525252525252fgemini%252525252525252525252525252525252fMain.aspx%252525252525252525252525252525253fReturnUrl%252525252525252525252525252525253d%25252525252525252525252525252525252fgemini%25252525252525252525252525252525252fMain.aspx%25252525252525252525252525252525253fReturnUrl%25252525252525252525252525252525253d%2525252525252525252525252525252525252fgemini%2525252525252525252525252525252525252fMain.aspx

So I started looking into things here and found some issues about redirecting but they all seemed to have to do with windows authentication, which I am not using.

I started to suspect that maybe it was something wrong with the anonymous user and so i tried altering the project schemas that it was associated with to no avial.  I even logged into another machine through remote desktop and tried to load the page in IE, but IE says it can't display the page either.  (although it doesn't display redirect behavior).

Yet it continues to work in my original instance of IE. And no issues are showing up in the System Log either.

Here is the part you will hate... I am running this from a shared hosting service under a DNN installation.  The gemini directory is set with its own application and i have made modifications to the web.config to account for the settings in the parent DNN web config.  Please help.  The installation is at http://www.atenveldt.org/gemini/

 

jjmartin
· 1
jjmartin
Replies (9)
helpful
0
not helpful

Ok i figured out something - its not much - but I can sorta get in now..

i took out the

<deny users="?"></deny>

in the authorization section of the web.config and I was able to get it not to spaz out redirecting.

But I can't seem to log in now either. 

I can browse the projects anonymously.  Using the IE session that is logged in, I can set the setting so that anonymous users can't browse.  this will make it so i can log in from the /default.aspx.

But a I can't seem to get to the point where a login is offered while at the Main.aspx.

I would like anonymous users to be able to browse, but you have to register to be able to submit issues.

 


jjmartin
· 1
jjmartin
helpful
0
not helpful

I suggest you re-install Gemini. That functionality comes with the default install.


Mark Wing
· 9108
Mark Wing
helpful
0
not helpful

I was hoping for a bit more help than that.  I can't readily run the re-install program on the shared hosted server and as I am running a non-standard installation with it being under DNN, i figure there is a configuration setting that I am missing somewhere that will probably fix the problem.


jjmartin
· 1
jjmartin
helpful
0
not helpful

We have quite a few customers who are running Gemini under DNN with no issues.

http://community.countersoft.com/forums/thread/2370.aspx

It might be your hosted environment, is it running under medium trust?

Also, try setting custom errors to off in the web.config file.


Saar Cohen
· 5000
Saar Cohen
helpful
0
not helpful

I am running under medium trust.  I saw that under 2.2 there is a setup that may work.  I will try that tonight.   The link to that other forum host wasn't particularly helpful, it didn't seem to have a resolved problem and I don't think its just a matter of running the sites on the same server but having the gemini directory set up as a subdirectory of the DNN installation i think is a bit more uncommon.

Custom errors are off already while i try to resolve this.

My main issue right now is that even if I manage to get logged in (by disabling anonymous logins - i will get a login screen before seeing anything else)  I never see the login controls on the project page (Main.aspx) and I don't see my login name/logout controls in the upper right corner.

I still need to try 2.2 with the settings for medium trust.  I will see if that makes a difference, My host has allowed reflection in addition to the medium trust, so the setting I saw in the faq area may not make any difference to me.


jjmartin
· 1
jjmartin
helpful
0
not helpful

I got a chance to try to install 2.2 and I am getting the same issue where I never see a login on the Main.aspx

I'm starting to think that this just won't work, I would be glad to invest the time in trying to fix it, but without the source code, i don't think I will be able to and since I am using this as a non-profit, I doubt you guys are very interested in spending much time on this.


jjmartin
· 1
jjmartin
helpful
0
not helpful

Hi,

We still need to understand what is causing it t fail under shared hosting DNN environment.

Can I presume Remote Desktop into the box won't work because you are on a shared hosting server?

Drop me a private message if you like so we can try to help out!


Harvey Kandola
· 212
Harvey Kandola
helpful
0
not helpful

Also, please send us your DNN web.config file.  The chances are we will have to apply some additional stuff to the Gemini web.config (because Gemini web app will inherit settings from parent DNN web.config?).


Harvey Kandola
· 212
Harvey Kandola
helpful
0
not helpful

I hope you will bear with me as I work on this site in my spare time (normally on weekends) and will have long pauses (2-5 days) between times when I can work on this.  I will get you my dnn web.config and my gemini web.config as soon as I get a chance to look this back up. 

I may just start with a clean DNN install and a clean Gemini install and see if I can accomplish it there before trying to get gemini to run under my actual site.   Have you tried to do this your self? (Clean installs?)

Thanks for your help, I was at the end of my patience on sunday.


jjmartin
· 1
jjmartin