Gemini Community Support Site

This Gemini community support site can be used to find solutions to product issues. You can log in using Open Id, Google Profile and even Facebook. Feel free to ask a question or browse FAQs and documentation. Product tour videos are also available along with how-to videos demonstrating key Gemini capabilities.




Directory Listing Denied

install

We have installed Gemini 5 into our server through automatic installer. It showed success message for installation but now when we go to http://servername/gemini it says "Directory Listing Denied This Virtual Directory does not allow contents to be listed."

We are using IIS 6 and we have already tried to configure IIS 6 according to the IIS 6 instructions on FAQ page and now it says "The page cannot be found".

We could not figure out what the problem is. Can you please advise on this?

Thanks

··· I have same issue. We use IIS 6. I followed this tutorial http://community.geminiplatform.com/faqs/46/using-iis-6-with-gemini-5stepand76Saturday, November 03, 2012, 9:51:33 PM
User42041
· 1
User42041
Replies (8)
helpful
0
not helpful

Is Gemini running under asp.net 4.0? Did you add the extensionless mapping (.*)?

··· sorry I hit the mark as answer by mistake... Yes Gemini is running under asp.net 4.0 and we have added c:\windows\microsoft.net\framework\v4.0.30319\aspnet_isapi.dll under application mapsUser42041Monday, November 05, 2012, 4:56:43 PM
··· but it is still not working...User42041Monday, November 05, 2012, 4:57:01 PM

Saar Cohen
· 5000
Saar Cohen
helpful
0
not helpful

We have the same issue. We use IIS 6. Followed this tutorial http://community.geminiplatform.com/faqs/46/using-iis-6-with-gemini-5 ...and it doesn't help. I is still same. What we have to check?


stepand76
· 504
stepand76
helpful
0
not helpful
ANSWER

I finally managed it to get it working. We have mixed (.NET2 and .NET4) environment on the server...

··· Hi Stepand76,User42041Monday, November 05, 2012, 4:12:10 PM
··· yes we also have both .NET2 and .NET4 environment on the server... can you please share how did you manage it?User42041Monday, November 05, 2012, 4:12:57 PM
··· Sorry, but I don't know. I followed the tutorial and it doesn't work. I checked the settings twice, restarted Gemini application, restarted whole server, it still doesnt work. Finally I found...stepand76Tuesday, November 06, 2012, 9:29:37 PM
··· ...that .NET4 is not enabled in Web Service Extensions. So I allowed it. Restarted server again. Checked it again. After some time I noticed it is running. I don't know what does help.stepand76Tuesday, November 06, 2012, 9:33:30 PM
··· Thanks a lot Stepand76! That did the trick. I had to allow .net4 under web service extensions in IIS 6User42041Tuesday, November 06, 2012, 10:17:00 PM

stepand76
· 504
stepand76
helpful
0
not helpful

Yes Gemini is running under asp.net 4.0 and we have added c:\windows\microsoft.net\framework\v4.0.30319\aspnet_isapi.dll under application maps as it is suggested in the faq section.


User42041
· 1
User42041
helpful
0
not helpful

Nobody has any idea how to solve this problem?


User42041
· 1
User42041
helpful
0
not helpful

The error suggests that the extensionless (.*) is not mapped. Is the site using .net 4.0?


Mark Wing
· 9108
Mark Wing
helpful
0
not helpful

Default website was using .net 2.0 and we have changed it to .net 4.0 and added application mapping from home directory tab to default website too.. still it does not work...

Default website and gemini they both are using .net 4.0 now... we also added .aspx and .mvc extension to both.. moreover ..\framework\v4.0.30319\aspnet_isapi.dll has been added to application maps for both...

what we are missing? any idea?


User42041
· 1
User42041
helpful
0
not helpful

Please send screenshots of all configurations to support@countersoft.com


Mark Wing
· 9108
Mark Wing