Gemini Community Support Site

This Gemini community support site can be used to find solutions to product issues. You can log in using Open Id, Google Profile and even Facebook. Feel free to ask a question or browse FAQs and documentation. Product tour videos are also available along with how-to videos demonstrating key Gemini capabilities.




server error !

web-app

hi

I installed gemini v3.1 but i got this error page ! please Advise

Server Error in '/Gemini' Application.

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load file or assembly 'Telerik.ReportViewer.WebForms, Version=2.5.8.414, Culture=neutral, PublicKeyToken=a9d7983dfcc261be' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

Source Error:

Line 49:                 <add assembly="System.Drawing.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
Line 50:                <add assembly="System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
Line 51:                <add assembly="Telerik.ReportViewer.WebForms, Version=2.5.8.414, Culture=neutral, PublicKeyToken=A9D7983DFCC261BE"/>
Line 52:                 <add assembly="Telerik.Reporting, Version=2.5.8.414, Culture=neutral, PublicKeyToken=A9D7983DFCC261BE"/>
Line 53:                <add assembly="Telerik.Reporting.Processing, Version=2.5.8.414, Culture=neutral, PublicKeyToken=A9D7983DFCC261BE"/>

Source File: C:\Program Files\CounterSoft\Gemini Project Issue Tracking\Gemini Web Application\web.config    Line: 51

Assembly Load Trace: The following information can be helpful to determine why the assembly 'Telerik.ReportViewer.WebForms, Version=2.5.8.414, Culture=neutral, PublicKeyToken=a9d7983dfcc261be' could not be loaded.

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.42

mts
· 1
mts
Replies (7)
helpful
0
not helpful

Is this an upgrade or a fresh install?


Saar Cohen
· 5000
Saar Cohen
helpful
0
not helpful

fresh , it didnt work with me to install 2 versions in same machine , so i installed v3.1 to evaluate it on new machine and it didnt work !


mts
· 1
mts
helpful
0
not helpful

Looks like your web.config file is not the 3.1 one. Did you copy an old one in?

The line should read (for all Telerik):

        <add assembly="Telerik.ReportViewer.WebForms, Version=2.9.8.1105, Culture=neutral, PublicKeyToken=a9d7983dfcc261be" />


Saar Cohen
· 5000
Saar Cohen
helpful
0
not helpful

i Re installed it and and i turned the cusstom errors on web.config off this message appears

Server Error in '/Gemini' Application.

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Theme 'Theme1' cannot be found in the application or global theme directories.

Source Error:

Line 43: 
Line 44: 
Line 45:     <pages theme="Theme1" styleSheetTheme="Theme1" validateRequest="false">
Line 46:       <controls>
Line 47:         <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>

Source File: c:\inetpub\wwwroot\web.config    Line: 45

Version Information: Microsoft .NET Framework


mts
· 1
mts
helpful
0
not helpful

i am not sure what is going on with your install but this web.config entry should not be there:

    <pages validateRequest="true" enableSessionState="true" enableViewState="true" enableViewStateMac="true" enableEventValidation="true">

Did you change it? Try removing the theme and stylesheet.


Saar Cohen
· 5000
Saar Cohen
helpful
0
not helpful

the problem with the web.config in wwwroot , gemini didnt read from web.config file in Gemni wep application folder , it reads the web.config in c:\inetpub\wwwroot\web.config  why !


mts
· 1
mts
helpful
0
not helpful

That is the way .NET works! Every web app will read this config as well as its own.

Why do you have it there?


Mark Wing
· 9108
Mark Wing