Gemini Community Support Site

This Gemini community support site can be used to find solutions to product issues. You can log in using Open Id, Google Profile and even Facebook. Feel free to ask a question or browse FAQs and documentation. Product tour videos are also available along with how-to videos demonstrating key Gemini capabilities.




Blank Emails

web-app

Hello,

I recently created a new project then deleted it. I don't know if this has any relation to my email issues, but ever since i did this, my emails have been coming back blank. No title or body.

 

Any possible explanation?

mumbles
· 1
mumbles
Replies (19)
helpful
0
not helpful

DEBUG 5/23/2007 11:42:28 AM   Error encountered processing template file: IssueAssignedSubjectLine.vm Object reference not set to an instance of an object. 5/23/2007 11:42:28 AM SOURCE: NVelocity TARGETSITE: Int32 IndexOf(System.Object) STACKTRACE: at Commons.Collections.LRUMap.IndexOf(Object key) at Commons.Collections.LRUMap.MoveToMRU(Object key) at Commons.Collections.LRUMap.getItem(Object key) at Commons.Collections.LRUMap.SyncLRUMap.getItem(Object key) at NVelocity.Runtime.Resource.ResourceCacheImpl.get(Object key) at NVelocity.Runtime.Resource.ResourceManagerImpl.GetResource(String resourceName, ResourceType resourceType, String encoding) at NVelocity.Runtime.RuntimeInstance.GetTemplate(String name, String encoding) at NVelocity.Runtime.RuntimeInstance.GetTemplate(String name) at NVelocity.Runtime.RuntimeSingleton.GetTemplate(String name) at NVelocity.App.Velocity.GetTemplate(String name) at CounterSoft.Gemini.Business.MailPlugin.MakeTemplate_NVelocity(IssueEventArgs args, String templateFile)


mumbles
· 1
mumbles
helpful
0
not helpful

Which version of Gemini are you running?

 


Mark Wing
· 9108
Mark Wing
helpful
0
not helpful

I am having the same issue. Everything was working fine for last 5 days and suddenly I have started getting blank emails. I am using the 2.1.1. Here's the error message.

 

DEBUG 5/24/2007 12:26:27 PM   Error encountered processing template file: IssueAssignedSubjectLine.vm Object reference not set to an instance of an object. 5/24/2007 12:26:27 PM SOURCE: NVelocity TARGETSITE: Int32 IndexOf(System.Object) STACKTRACE: at Commons.Collections.LRUMap.IndexOf(Object key) at Commons.Collections.LRUMap.MoveToMRU(Object key) at Commons.Collections.LRUMap.getItem(Object key) at Commons.Collections.LRUMap.SyncLRUMap.getItem(Object key) at NVelocity.Runtime.Resource.ResourceCacheImpl.get(Object key) at NVelocity.Runtime.Resource.ResourceManagerImpl.GetResource(String resourceName, ResourceType resourceType, String encoding) at NVelocity.Runtime.RuntimeInstance.GetTemplate(String name, String encoding) at NVelocity.Runtime.RuntimeInstance.GetTemplate(String name) at NVelocity.Runtime.RuntimeSingleton.GetTemplate(String name) at NVelocity.App.Velocity.GetTemplate(String name) at CounterSoft.Gemini.Business.MailPlugin.MakeTemplate_NVelocity(IssueEventArgs args, String templateFile)


shahidmughal
· 1
shahidmughal
helpful
0
not helpful

Yikees!

This just happen to me as well...

It is shutting me down on 7 projects. I am on 1.9b

The only thing I did differenrly was install Gemini desktop. - I don't know if this is even related

Please help!

Ken Stilwell

Stilwell Consulting Group (ken@stilwellconsulting.com)


kstilwell2000
· 1
kstilwell2000
helpful
0
not helpful

All we can suggest for 1.9.x is to reboot.


Saar Cohen
· 5000
Saar Cohen
helpful
0
not helpful

Yes, rebooting worked.

Thanks,

Ken Stilwell


kstilwell2000
· 1
kstilwell2000
helpful
0
not helpful

Rebooting works but after 5 or 6 days you need to reboot again. Can we get a permanent solution for this problem.

Thanks

Shahid


shahidmughal
· 1
shahidmughal
helpful
0
not helpful

What version of Gemini are you running?


Saar Cohen
· 5000
Saar Cohen
helpful
0
not helpful

We have 2.1.1 and having the same issue. After reboot the mails are ok again.


deniz
· 1
deniz
helpful
0
not helpful

This issue has been addressed in 2.2 release.


Saar Cohen
· 5000
Saar Cohen
helpful
0
not helpful

[quote user="SaarCohen"]This issue has been addressed in 2.2 release.[/quote]

No, it doesn't. Today I have received more than 10 blank emails from Gemini 2.2.7.


DEBUG 15/04/2008 14:04:07   Error encountered processing template file: IssueCommentSubjectLine.vm
Object reference not set to an instance of an object. 15/04/2008 14:04:07 SOURCE: NVelocity TARGETSITE: Int32 IndexOf(System.Object) STACKTRACE: at Commons.Collections.LRUMap.IndexOf(Object key) at Commons.Collections.LRUMap.MoveToMRU(Object key) at Commons.Collections.LRUMap.getItem(Object key) at Commons.Collections.LRUMap.SyncLRUMap.getItem(Object key) at NVelocity.Runtime.Resource.ResourceCacheImpl.get(Object key) at NVelocity.Runtime.Resource.ResourceManagerImpl.GetResource(String resourceName, ResourceType resourceType, String encoding) at NVelocity.Runtime.RuntimeInstance.GetTemplate(String name, String encoding) at NVelocity.Runtime.RuntimeInstance.GetTemplate(String name) at NVelocity.Runtime.RuntimeSingleton.GetTemplate(String name) at NVelocity.App.Velocity.GetTemplate(String name) at CounterSoft.Gemini.Business.MailPlugin.MakeTemplate_NVelocity(IssueEventArgs args, String templateFile)


stepand76
· 504
stepand76
helpful
0
not helpful

Can you switch to the scheduler?


Mark Wing
· 9108
Mark Wing
helpful
0
not helpful

[quote user="MarkWing"]Can you switch to the scheduler?[/quote]

I hope, but I don't know when, because of Gemini is critical for us at the moment...


stepand76
· 504
stepand76
helpful
0
not helpful

Ok, I tried to switch to Gemini Scheduler. Result is it doesn't send any emails. And eats memory (700MB). See the screenshot:

http://www.reliance.cz/temp/GeminiSchedulerServiceInTaskManager.png

Here is my CounterSoft.Gemini.Scheduler.exe.config:

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
  <configSections>
    <section name="Gemini" type="CounterSoft.Gemini.Scheduler.ServiceConfigSection, CounterSoft.Gemini.Scheduler" />
  </configSections>
  <Gemini>
    <Clients>
      <Client WebServicesURL="http://airforceone/gemini/webservices" AuthenticationUsername="admin" AuthenticationPassword="xxxxxxxxxxxxxx">
        <MailboxProcessors>
          <!-- Sample mailbox processor setup
          <MailboxProcessor
            Name="MyPOP1"
            POPServer="mail.server.com"
            POPServerPort="110"
            AuthenticationMethod="AUTO"
            UseSSL="false"
            POPMailbox="a@server.com"
            POPUsername="a@server.com"
            POPPassword="abc123"
            DeleteMessages="false"
            SubjectLikeRegExp=""
            SubjectNOTLikeRegExp=""
            ProjectID="1"
            UserID="1"
            ComponentID="1"
            IssueType="1"
            IssuePriority="1"
            DebugFile = "c:\GeminiPOP3log.txt"
            DebugMode = "false"
            />
          -->
          <!-- Authentication methods: AUTO, APOP, REGULAR, NONE  -->
          <!-- POP Server Port: usually 110 or 995 (secure) -->
        </MailboxProcessors>
        </Client>
    </Clients>
  </Gemini>
</configuration>


What's wrong?


stepand76
· 504
stepand76
helpful
0
not helpful

Hmm, now me and my colleges have received cca 500 of  strange emails with "Gemini Email Alert" subject. Body of these email contains only issue Id. Switching back to Mail plugin...


stepand76
· 504
stepand76
helpful
0
not helpful

Don't worry about those. It is all the alerts that were queued. Once the queue is empty you should be ok.


Mark Wing
· 9108
Mark Wing
helpful
0
not helpful

[quote user="MarkWing"]Don't worry about those. It is all the alerts that were queued. Once the queue is empty you should be ok.[/quote]

Should I let Gemini send thousands of emails to my colleges and customers? I don't know if it is good idea...

What is the purpose of these emails?


stepand76
· 504
stepand76
helpful
0
not helpful

I agree, it is not a good idea. You can truncate the issuealerts table.

This table is populated so the scheduler can batch emails.


Mark Wing
· 9108
Mark Wing
helpful
0
not helpful

[quote user="MarkWing"]

I agree, it is not a good idea. You can truncate the issuealerts table.

This table is populated so the scheduler can batch emails.

[/quote]

I have deleted the table (19000 rows!!!). Now it looks OK. We will see if this solve blank emails issue. Thank you.


stepand76
· 504
stepand76