Gemini Community Support Site

This Gemini community support site can be used to find solutions to product issues. You can log in using Open Id, Google Profile and even Facebook. Feel free to ask a question or browse FAQs and documentation. Product tour videos are also available along with how-to videos demonstrating key Gemini capabilities.




Windows authentication with TFS Check-In Policy plugin

visual-studio

Hi,

I've installed the TFS check-in policy plugin for VS2010. When I try to create a new gemini check-in policy, I'm unable to use windows authentication. Upon attempting to save such a policy, VS locks up for ~5 minutes and finally displays an error that says: "Gemini website is not configured to accept GET/POST/PUT/DELETE Http Verbs(.ashx)?"

We login through the web interface to the same website with windows authentication and it works fine. Any idea what's causing this behavior?

Thanks, Matthew

EDIT: As a side note, I also have the Gemini VS plugin and am successfully using Windows Authentication to the same URL.

mfotzler
· 1
mfotzler
Replies (5)
helpful
0
not helpful

Can you please use fiddler to check the response from the server?


Mark Wing
· 9108
Mark Wing
helpful
0
not helpful

Hi Mark,

I'm new to Fiddler and don't know much about HTTP responses. Here are the responses when I try to save the check-in policy. (Sorry, I don't see a way to attach rather than paste..)

Matt

GET http://gemini/api/admin.ashx/test HTTP/1.1

Accept: text/xml Content-Type: text/xml Host: gemini

HTTP/1.1 401 Unauthorized Content-Type: text/html Server: Microsoft-IIS/7.5 WWW-Authenticate: Negotiate WWW-Authenticate: NTLM X-Powered-By: ASP.NET Date: Wed, 01 Feb 2012 20:00:33 GMT Content-Length: 1293 Proxy-Support: Session-Based-Authentication

401 - Unauthorized: Access is denied due to invalid credentials.

header{width:96%;margin:0 0 0 0;padding:6px 2% 6px 2%;font-family:"trebuchet MS", Verdana, sans-serif;color:#FFF;

background-color:#555555;}

content{margin:0 0 0 2%;position:relative;}

.content-container{background:#FFF;width:96%;margin-top:8px;padding:10px;position:relative;} -->

Server Error

401 - Unauthorized: Access is denied due to invalid credentials.

You do not have permission to view this directory or page using the credentials that you supplied.


GET http://gemini/api/admin.ashx/test HTTP/1.1 Accept: text/xml Content-Type: text/xml Authorization: Negotiate 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 Host: gemini

HTTP/1.1 200 OK Cache-Control: no-cache Pragma: no-cache Content-Type: text/xml Expires: -1 Server: Microsoft-IIS/7.5 X-AspNet-Version: 2.0.50727 Persistent-Auth: false X-Powered-By: ASP.NET WWW-Authenticate: Negotiate oYG2MIGzoAMKAQChCwYJKoZIgvcSAQICooGeBIGbYIGYBgkqhkiG9xIBAgICAG+BiDCBhaADAgEFoQMCAQ+ieTB3oAMCARKicARu42JsZb8B3mlhkXRPdqro/cKTs+W2BvRSRdQymKmNPJ/1XXeZE5OwVwKfcyCXH8OtAWkdGOpX7mciovuZjFkEwddTZ1k8/rG5p3N6LRRuVE0/x7BLHN59OrrCU6RIzU3v68NhJWFHyZiseAe0+Hc= Date: Wed, 01 Feb 2012 20:00:33 GMT Content-Length: 60

OK


PUT http://gemini/api/admin.ashx/test HTTP/1.1 Accept: text/xml Content-Type: text/xml Host: gemini Content-Length: 62 Expect: 100-continue

test HTTP/1.1 401 Unauthorized Content-Type: text/html Server: Microsoft-IIS/7.5 WWW-Authenticate: Negotiate WWW-Authenticate: NTLM X-Powered-By: ASP.NET Date: Wed, 01 Feb 2012 20:00:33 GMT Content-Length: 1293 Proxy-Support: Session-Based-Authentication

401 - Unauthorized: Access is denied due to invalid credentials.

header{width:96%;margin:0 0 0 0;padding:6px 2% 6px 2%;font-family:"trebuchet MS", Verdana, sans-serif;color:#FFF;

background-color:#555555;}

content{margin:0 0 0 2%;position:relative;}

.content-container{background:#FFF;width:96%;margin-top:8px;padding:10px;position:relative;} -->

Server Error

401 - Unauthorized: Access is denied due to invalid credentials.

You do not have permission to view this directory or page using the credentials that you supplied.


PUT http://gemini/api/admin.ashx/test HTTP/1.1 Accept: text/xml Content-Type: text/xml Authorization: Negotiate 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 Host: gemini Content-Length: 62 Expect: 100-continue

test HTTP/1.1 401 Unauthorized Cache-Control: private Content-Type: text/html Server: Microsoft-IIS/7.5 X-AspNet-Version: 2.0.50727 WWW-Authenticate: Negotiate WWW-Authenticate: NTLM X-Powered-By: ASP.NET Date: Wed, 01 Feb 2012 20:00:33 GMT Content-Length: 1293 Proxy-Support: Session-Based-Authentication

401 - Unauthorized: Access is denied due to invalid credentials.

header{width:96%;margin:0 0 0 0;padding:6px 2% 6px 2%;font-family:"trebuchet MS", Verdana, sans-serif;color:#FFF;

background-color:#555555;}

content{margin:0 0 0 2%;position:relative;}

.content-container{background:#FFF;width:96%;margin-top:8px;padding:10px;position:relative;} -->

Server Error

401 - Unauthorized: Access is denied due to invalid credentials.

You do not have permission to view this directory or page using the credentials that you supplied.


GET http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd HTTP/1.1 Host: www.w3.org

HTTP/1.1 504 Fiddler - Receive Failure Content-Type: text/html; charset=UTF-8 Connection: close Timestamp: 14:01:04.101

ReadResponse() failed: The server did not return a response for this request.


GET http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd HTTP/1.1 Host: www.w3.org

HTTP/1.1 504 Fiddler - Receive Failure Content-Type: text/html; charset=UTF-8 Connection: close Timestamp: 14:01:34.187

ReadResponse() failed: The server did not return a response for this request.



mfotzler
· 1
mfotzler
helpful
0
not helpful

When you click on the windows authentication checkbox, do you see your username in the box?


Mark Wing
· 9108
Mark Wing
helpful
0
not helpful

No, the form has "admin" in the box by default even after I check the windows authentication checkbox. I've tried changing it to my username also, but the result is the same as what I posted above.


mfotzler
· 1
mfotzler
helpful
1
not helpful
ANSWER

Ok, put your username (domain\user) and then click on the win auth checkbox. The error is to do with windows permissions on the api folder of Gemini. Please add the full permissions to the everyone group on the api folder which is under the root of your Gemini site.

··· Thank you!mfotzlerFriday, February 03, 2012, 3:02:57 PM

Mark Wing
· 9108
Mark Wing