Home Home
  login

Gemini Community Support Site

This Gemini community support site can be used to find solutions to product issues. You can log in using Open Id, Google Profile and even Facebook. Feel free to ask a question or browse FAQs and documentation. Product tour videos are also available along with how-to videos demonstrating key Gemini capabilities.




Client home page - straight to items list

security

On the video demo, "Help Desk: Giving Access to Your Clients" (http://community.geminiplatform.com/videos/11/help-desk-giving-access-to-your-clients/), it shows the customer logging in and going immediately to the list of items created by or assigned to that customer. Moreover, the customer doesn't see any menu items that might lead anywhere else. Nice and clean. I want that.

What specific permissions do I need to define to produce that effect? I have created a permissions group for the Help Desk, and a global group called "Customers". The profile permissions for a logged-in customer look like this:

Project: Help Desk

Permissions: View Project, View Documents, Only View Own Items, Create Item, Create Comment.

But when I log in as a customer, it takes me to the Project, HELP: Help Desk page, which has the Summary, Items, Road Map, Change Log, Documents, Reports menu. I want customers to go straight to the Items page, and not even see all those other menu choices. I want the nice clean experience shown in the video. How do I do this?

User29573
· 1
User29573
Replies (6)
helpful
0
not helpful

Please make sure that the Help desk user group located in Administrations --> General under security is set to the correct group.


Simran
· 1762
Simran
helpful
0
not helpful

OK -- on that page, I designated the Customers user group as the "Help Desk User Group". Now when I log in as a customer, I see the nice clean page, as requested.

But when I click New Item, enter a title, and click Add, nothing happens. No error message, no spinning circle (hourglass), nothing changes on the screen at all.


User29573
· 1
User29573
helpful
0
not helpful

It seems like the required field (components, description) is hidden from the user. Please either show these fields or set default values via Project Administration --> default values.


Simran
· 1762
Simran
helpful
0
not helpful

Thanks -- I made the description field visible (components already had a default), and the Add button now works. Almost. The customer cannot see any items at all. If I log in as myself, I can see the new item sitting there at the top of the Items list. But if I log in as the customer, I see nothing.

It sure would be helpful to have a setup guide that explains all the settings you need to use to create the effect shown in the video. Or have I overlooked something in the docs?


User29573
· 1
User29573
helpful
0
not helpful

Is the customer part of the everyone group?

Have you checked the item visibility to see if the customer is in the group that the item is visible too?

Who has created the item the customer or you?


Simran
· 1762
Simran
helpful
0
not helpful

The customer was not in the Everyone group. I added the customer to that group, and now the items are visible.

Next: when the customer hits Edit, the customer can see a bunch of fields that I don't want them to see -- like Component, Resource, etc. So how do I prevent the customer from seeing them? I have created a new screen definition called Help request, and selected it on the project admin page. In that screen definition, I permitted toe Component field to our internal company group and did not permit it to Everyone or Customers. But the customer can still see it.

This seems to never end. PLEASE -- is there a complete guide to setting up Gemini for controlled customer visibility? I don't want the customer to see the fields that relate to internal company concerns (e.g. Estimate Effort, Component, Fixed in Version, etc.). But I do need those fields visible when the item is being edited by one of our internal users.


User29573
· 1
User29573